mirror of
https://github.com/storytold/pdfcraft.git
synced 2026-11-03 09:10:33 +00:00
Merge pull request #4880 from storytold/fix/nextest-0.9.150
ci: require nextest 0.9.150
This commit is contained in:
2 files changed
+4
-1
No files matched your search
@@ -0,0 +1,3 @@
|
|||||||
|
# Minimum cargo-nextest for this repository: GHSA-vc25-qg58-w57c is fixed in 0.9.150 and CI
|
||||||
|
# installs exactly that version, so an older nextest refuses to run (exit 92 REQUIRED_VERSION_NOT_MET).
|
||||||
|
nextest-version = "0.9.150"
|
||||||
@@ -82,7 +82,7 @@ jobs:
|
|||||||
libxkbcommon-dev libwayland-dev libx11-dev libxrandr-dev libxi-dev libgl1-mesa-dev
|
libxkbcommon-dev libwayland-dev libx11-dev libxrandr-dev libxi-dev libgl1-mesa-dev
|
||||||
libgtk-3-dev qpdf poppler-utils
|
libgtk-3-dev qpdf poppler-utils
|
||||||
# cargo-deny for the deny step of `cargo xtask ci`, which requires it under CI.
|
# cargo-deny for the deny step of `cargo xtask ci`, which requires it under CI.
|
||||||
tools: cargo-nextest@0.9.149,cargo-deny@0.20.2
|
tools: cargo-nextest@0.9.150,cargo-deny@0.20.2
|
||||||
# A missing oracle fails the job instead of printing a skip notice that reads as a pass.
|
# A missing oracle fails the job instead of printing a skip notice that reads as a pass.
|
||||||
linux-env: PDFCRAFT_ORACLES_REQUIRED=1
|
linux-env: PDFCRAFT_ORACLES_REQUIRED=1
|
||||||
windows-env: PDFCRAFT_REQUIRE_WINRES=1
|
windows-env: PDFCRAFT_REQUIRE_WINRES=1
|
||||||
|
|||||||
Reference in new issue
Block a user